2013年4月1日 星期一

100 - The 3n + 1 problem

Background

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

The Problem

Consider the following algorithm:
 
  1.    input n

  2.    print n



  3.    if n = 1 then STOP



  4.       if n is odd then  tex2html_wrap_inline44 



  5.       else  tex2html_wrap_inline46 



  6.    GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1
It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)
Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.
For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

The Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.
You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.
You can assume that no operation overflows a 32-bit integer.

The Output

For each pair of input integers i and j you should output ij, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

出處: UVa Online Judge - The 3n + 1 problem


問題敘述

此問題會輸入好幾組資料,每組資料有2個數字,您要從這對數字的範圍中取出每個數字當數列的起點,並且找出最長的數列長度。數列的規則如下: 假設某一項的內容為n,且n為奇數,則下一項的內容為3 * n + 1,若n為偶數,則下一項的內容為n / 2,一直到n為1數列就結束。輸出時必須照原本輸入的數字印出(順序不能對調),且還要印出最長的數列長度。

解題思路

沒有什麼特別的思路,就單純照著題目的說明做,比較需要注意的是輸入的範圍可能大的數字會在前面,小的數字在後面,輸出時必須按照輸入的順序輸出,不然會wrong answer。

c++程式碼

#include <iostream>
using namespace std;

int findLength(int num) {
    if (num == 1)
        return 1;
    else {
        if (num % 2)
            return 1 + findLength(3 * num + 1);
        else
            return 1 + findLength(num / 2);
    }
}

int main() {
    int startRange, endRange;

    while (cin >> startRange >> endRange) {
        bool isSwap = false;
        int maxLength = 0;

        if (startRange > endRange) {
            swap(startRange, endRange);
            isSwap = true;
        }
        for (int i=startRange; i<=endRange; i++) {
            int length = findLength(i);

            if (length > maxLength)
                maxLength = length;
        }
        if (isSwap)
            swap(startRange, endRange);
        cout << startRange << " " << endRange << " " << maxLength << endl;
    }

    return 0;
}

沒有留言:

張貼留言