2013年8月18日 星期日

591 - Box of Bricks

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?


Input 

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains nnumbers, the heights hi of the n stacks. You may assume $1 Ÿ\le n \leŸ 50$ and $1 \leŸ h_i Ÿ\le 100$.
The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.
The input is terminated by a set starting with n = 0. This set should not be processed.

Output 

For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', wherek is the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line after each set.

Sample Input 

6
5 2 4 1 7 5
0

Sample Output 

Set #1
The minimum number of moves is 5.

出處: http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=7&page=show_problem&problem=532



題目要求您要用最少的移動次數移動積木,來把每一堆積木都變得一樣高,題目假設總積木數除以積木堆數都有辦法整除,也就是說積木經過移動後都有辦法變得一樣高。既然要用最少的次數移動,那每一次移動就要把最高的積木堆拿一個積木下來填補到最低的積木堆,一直到每個積木堆都一樣高為止。

c++ code:

#include <iostream>
#include <vector>
using namespace std;

int main() {
    int setCount = 0;

    while (true) {
        int n;
        vector<int> heights;
        int moveCount = 0;

        cin >> n;
        if (n == 0)
            break;
        setCount++;
        for (int i=0; i<n; i++) {
            int h;

            cin >> h;
            heights.push_back(h);
        }
        while (true) {
            int max = heights[0];
            int min = heights[0];
            int maxIndex = 0;
            int minIndex = 0;

            for (int i=1; i<heights.size(); i++) {
                if (heights[i] > max) {
                    max = heights[i];
                    maxIndex = i;
                }
                else if (heights[i] < min) {
                    min = heights[i];
                    minIndex = i;
                }
            }
            if (max == min)
                break;
            moveCount++;
            heights[maxIndex]--;
            heights[minIndex]++;
        }
        cout << "Set #" << setCount << endl;
        cout << "The minimum number of moves is " << moveCount << ".\n\n";
    }

    return 0;
}

沒有留言:

張貼留言